Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC:

Link in user email not working 1 year 1 month ago #28909

If I add a user in the backend to an event, he gets an email. it contains a direct link to the event, but this links does not work! 

it leads to an error "FEHLER
Veranstaltung nicht gefunden!

Es ist ein Fehler aufgetreten!"

How can I make the link work?

And how can I change the text in this email?

Please Log in or Create an account to join the conversation.

Link in user email not working 1 year 1 month ago #28910

Just curious..

Is your site using https or http..? And what about the configuration of the link?

Please Log in or Create an account to join the conversation.

Link in user email not working 1 year 1 month ago #28912

Right now it uses http but it should use https. The events are for registered only, that might be the problem.

if I am logged in and open the event, the url looks like this: hhtp://xxx/veranstaltungen/event/1

in the email it looks totally different

Please Log in or Create an account to join the conversation.

Link in user email not working 1 year 1 month ago #28913

  • jojo12
  • jojo12's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 3507
  • Thank you received: 395
Do you have SEF URL enabled or disabled? Is it possible it has to do with this?

EDIT: I tried in my latest Joomla, latest JEM, with both settings, the links in the email worked fine for me! Must be something other in your system.

Please Log in or Create an account to join the conversation.

Last edit: by jojo12.

Link in user email not working 1 year 1 month ago #28914

SEF URL is enabled. I think it has to do with the events being for registered only. So if a user clicks on a link in the mail the event can not be shown, because he is not logged in. It should display a login form and the redirect to the event. instead it shows an error of the event not being found
The following user(s) said Thank You: jojo12

Please Log in or Create an account to join the conversation.

Link in user email not working 1 year 1 month ago #28916

  • jojo12
  • jojo12's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 3507
  • Thank you received: 395
Would this help, if in the email is something like: "(In some cases) you need to login first!" ?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.396 seconds

Donate

If you find JEM useful and if you use it on your site, please consider a donation to the project.

Private Messages

You are not logged in.

Follow us......