Welcome, Guest
Username: Password: Remember me

TOPIC: The Responsive JEM

The Responsive JEM 1 year 7 months ago #24706

  • HerKle
  • HerKle's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Style is poor man's basic right
  • Posts: 154
  • Thank you received: 23
The test runs locally on xampp. So it shouldn't be a rights' issue.
Firefox and Chrome show both the same behaviour.
But you are right, the web dev tools show no reference to your css files in the templates' css sub-directories.
Regards,
Herbert
The topic has been locked.

The Responsive JEM 1 year 7 months ago #24707

  • Egnarts
  • Egnarts's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 262
  • Karma: -3
  • Thank you received: 110
Never say there are no right problems because I use a local test-environement :D

I tried to find your template in the internet but I think it's a self-developed template?
Would you like to give me a download link (via personal msg) to the templete? I would likte to use it in my development tests.

While I was looking at your sites source code, I found out that the "old" jem.css is also not included in the references as it is.
It is included via /templates/protogutt/css/jemgt.css?c1f7b48d2f77dc99995ad322098d0e17. So I assume you use a css generator?
Eventually this could be the problem; your template includes just "generated" css and not default css from templates' css sub-directory.
Take a look at the responsive version of JEM: The Responsive JEM
The topic has been locked.

The Responsive JEM 1 year 7 months ago #24708

  • HerKle
  • HerKle's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Style is poor man's basic right
  • Posts: 154
  • Thank you received: 23
The template protogutt is Joomla's default Protostar with a custom css file "user.css". It's renamed to keep it untouched by Joomla updates. If you still want to have it, I can deliver the link.

The jem.css is loaded after user.css. So none of the changes made there are working for JEM. For that scenario JEM provides in its settings "List layout" the possibility for custom stylesheets.There I deactivated jem.css and replaced it by the path to templates/protogutt/css/jemgt.css, which is mostly a copy of jem.css with some minor changes to apply with the general layout.
Regards,
Herbert
The topic has been locked.

The Responsive JEM 1 year 7 months ago #24719

  • Egnarts
  • Egnarts's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 262
  • Karma: -3
  • Thank you received: 110
Okay, then I don't need the template.
JEM Responsive normally works with protostar, thats mysterious...
Did you tried to include the override jem.ss via the setting in the backend?
Take a look at the responsive version of JEM: The Responsive JEM
Last edit: by Egnarts.
The topic has been locked.

The Responsive JEM 1 year 7 months ago #24727

  • HerKle
  • HerKle's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Style is poor man's basic right
  • Posts: 154
  • Thank you received: 23
What do you mean? Anything else than what I described already (List layout settings, name path)?
Regards,
Herbert
The topic has been locked.

The Responsive JEM 1 year 7 months ago #24728

  • Egnarts
  • Egnarts's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 262
  • Karma: -3
  • Thank you received: 110

There I deactivated jem.css and replaced it by the path to templates/protogutt/css/jemgt.css, which is mostly a copy of jem.css with some minor changes to apply with the general layout.


Did you try this, using my jem.css instead of your jemgt.css?

I think that is why my jem.css is not working. Because JEM looks by default for its jem.css. And with my override, some joomla mechanics say to JEM that my override-jem.css is the original css. But because you disabled the jem.css, joomla does not look for any jem.css file anymore, just using your jemgt.

--

Und nochmal auf deutsch, damit wir uns auch genau verstehen:
Ich denke wenn du diese Einstellung nicht gesetzt hast, sucht JEM normalerweise nach seiner jem.css. Jetzt gibts aber irgendwelche Joomla-Mechaniken, die eben genau Overrides ermöglichen. Diese Mechaniken ersetzen jetzt gegenüber JEM, die Standard-jem.css mit meiner Ovberride-jem.css. Da du aber die Einstellung gesetzt hast, dass JEM eine eigene jem.css von sonst wo her nehmen soll, sind die Joomla-Mechaniken überschrieben und er nimmt stur die Datei, die du da angegeben hast. Deswegen gib in diesem Pfad mal meine jem.css vom Override an, dann sollte es vermutlich funktionieren.
Take a look at the responsive version of JEM: The Responsive JEM
Last edit: by Egnarts.
The topic has been locked.
Time to create page: 0.283 seconds

Donate

If you find JEM useful and if you use it on your site, please consider a donation to the project.

Private Messages

You are not logged in.