Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Upgrade check Error Message 3 years 1 month ago #24789

  • chrisd
  • chrisd's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 46
  • Thank you received: 9
Dear all,
I have got these messages this morning when checking my joomla extensions for any available updates in the backend (Extensions | Manage | Update | Clear Cache , Find Updates) :

Update: Could not open update site #39 "JEM Update Site", URL: www.joomlaeventmanager.net/updatecheck/update_pkg_jem.xml
Update: Could not open update site #43 "JEM Update Site", URL: www.joomlaeventmanager.net/updatecheck/u...cymailing_tagjem.xml
Update: Could not open update site #44 "JEM Update Site", URL: www.joomlaeventmanager.net/updatecheck/u...agjem_multi-lang.xml

Trying to open the URLs I'm successful and Firefox displays the xml content.
I could update some other extensions successfully.

When using the update button in JEM I get the following message:
Update server currently not available. Please try again later!

Using:
Joomla! 3.8.3 Stable
php 7.1.13
JEM 2.2.2

I'm aware that I'm on the current version but I wouldn't expect to see theses kind of errors if all works correctly. Hence my query to the forum if others are experiencing them or what to do to not get them.

Thanks
chrisd

Please Log in or Create an account to join the conversation.

Upgrade check Error Message 3 years 1 week ago #24896

  • chrisd
  • chrisd's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 46
  • Thank you received: 9
Hi,
I'm now trying to upgrade to the new 2.2.3 via the update check menu entry.
I keep getting the message...
Update server currently not available. Please try again later!
Installed Version: 	2.2.2

Any ideas on this?

Cheers
chrisD

Please Log in or Create an account to join the conversation.

Upgrade check Error Message 3 years 1 week ago #24897

Hi there Chris,

I've just checked and everything is up and running.

I think you just have to try again. Since the release last Monday more 320 updates have taken place, so it's definitely working....

There is a bot checking the uptime of our site... I just checked.. but the bot is down :laugh:
JEM 2.3.0
Joomla 3.9.20
PHP 7.1
The following user(s) said Thank You: chrisd

Please Log in or Create an account to join the conversation.

Upgrade check Error Message 3 years 1 week ago #24898

And here are the uptime details...:


So it might have been a small flaw. Did you retry already?
JEM 2.3.0
Joomla 3.9.20
PHP 7.1
Attachments:

Please Log in or Create an account to join the conversation.

Upgrade check Error Message 3 years 1 week ago #24899

  • chrisd
  • chrisd's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 46
  • Thank you received: 9
Hi ernst67,
thanks for checking. Yes, I have tried several times since the last post and no luck still.
Have now successfully updated by manually downloading and installing the latest version.

And still with 2.2.3 I get the same message :-(

Very bizarre

chrisd

Please Log in or Create an account to join the conversation.

Upgrade check Error Message 3 years 1 week ago #24901

  • Hoffi
  • Hoffi's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2279
  • Karma: 52
  • Thank you received: 449
Hi Chris,

chrisd wrote: Hi,
I'm now trying to upgrade to the new 2.2.3 via the update check menu entry.

Do you mean the Update check of JEM? This is a check only (which I must redesign or remove because we support Joomla's update mechanism yet). To update JEM you must use Joomla's extension manager.

But regarding the "server not available" messages:
Is this limited to JEM? Are other update sites accessible? (e.g. via Extensions - Manager - Updates) - otherwise maybe a problem with cURL.
Another idea: Have you configured your site to Force HTTPS? (on Global Configuration - Server Settings) Maybe your site is not willing to use http w/o ssl/tls.
Because I don't have a ssl site I can't test this. You could change the "http..." url to "https.." in file administrator/components/com_jem/models/updatecheck.php (line 36) and then try JEM's Update check menu entry.
Wrong idea. Brought one of my hosts to tls and played around - no problem found. http urls works also fine with Force HTTPS set to anything other than None. So my only idea left yet is a problem with cURL or somewhat on server is filtering out hosts or ip address ranges - why ever.
Pessimists are optimists with experience!

Please Log in or Create an account to join the conversation.

Last edit: by Hoffi.
  • Page:
  • 1
Time to create page: 0.352 seconds

Donate

If you find JEM useful and if you use it on your site, please consider a donation to the project.

Private Messages

You are not logged in.

Follow us......