Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Error in german language file plg_jem_mailer.ini 6 months 3 weeks ago #27038

  • MartinK
  • MartinK's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 2
Hi all
I just noticed an error in the german language file plg_jem_mailer.ini which causes the file not to be loaded:
on line 200
PLG_JEM_MAILER_LOG_SEND_ERROR="Fehler beim Senden einer Emails an "_QQ_"%s"_QQ_"_QQ_
at the end "_QQ_ has to be removed in order to work (compared to the english version)
This bug may be due to strange Transifex behavior
Discussed here: issues.joomla.org/tracker/joomla-cms/15378
HTH
The following user(s) said Thank You: jojo12

Please Log in or Create an account to join the conversation.

Error in german language file plg_jem_mailer.ini 6 months 3 weeks ago #27049

  • jojo12
  • jojo12's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 3295
  • Karma: 45
  • Thank you received: 357
Indeed there's something really strange!
on JEM 2.3.0 stable in latest Joomla (3.9.22) Protostar php7.4.5

Please Log in or Create an account to join the conversation.

Error in german language file plg_jem_mailer.ini 6 months 2 weeks ago #27050

A bit of research and I found this:

The Transifex files are linked to the source on Github. Every 24 Transifex is updated automatically.

The link to Github for this pluging is at:
raw.githubusercontent.com/jemproject/JEM...B.plg_jem_mailer.ini

And the string reads:
PLG_JEM_MAILER_LOG_SEND_ERROR="Error sending email to "_QQ_"%s"_QQ_
but off course it should be:
PLG_JEM_MAILER_LOG_SEND_ERROR="Error sending email to "_QQ_"%s"_QQ_"

The only way to correct this is to update the Github source.

Let me discuss with Jojo via PM
JEM 2.3.0
Joomla 3.9.20
PHP 7.1

Please Log in or Create an account to join the conversation.

Error in german language file plg_jem_mailer.ini 6 months 2 weeks ago #27064

  • jojo12
  • jojo12's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 3295
  • Karma: 45
  • Thank you received: 357
I tried with
PLG_JEM_MAILER_LOG_SEND_ERROR="Error sending email to "_QQ_"%s"_QQ_"
but then the language file isn't working
so I propose:

PLG_JEM_MAILER_LOG_SEND_ERROR="Error sending email to %s"

Then the language file is working, but how can I test the email?
Does anyone know, what I have to do to get an email with this error notice?
on JEM 2.3.0 stable in latest Joomla (3.9.22) Protostar php7.4.5

Please Log in or Create an account to join the conversation.

Error in german language file plg_jem_mailer.ini 6 months 1 week ago #27068

  • MartinK
  • MartinK's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 2
This message is used only in logging as far as i can see in the code.
You have turn on Joomla Debugging (see here docs.joomla.org/Using_JLog ) and you have to set the debug plugin to log almost everything. Then change an email adress to a wrong adress and book an event this user.
I have used your PLG_JEM_MAILER_LOG_SEND_ERROR in my german language file and it worked
from the log file:
2020-05-12T21:07:58+00:00 WARNING ::1 jem Error sending email to This email address is being protected from spambots. You need JavaScript enabled to view it. : SMTP-Fehler! Die folgenden Empfänger sind nicht korrekt: This email address is being protected from spambots. You need JavaScript enabled to view it.: <This email address is being protected from spambots. You need JavaScript enabled to view it.>: Recipient address rejected: User unknown in virtual mailbox table
HTH
The following user(s) said Thank You: jojo12

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.263 seconds

Donate

If you find JEM useful and if you use it on your site, please consider a donation to the project.

Private Messages

You are not logged in.

Follow us......