Welcome, Guest
Username: Password: Remember me

TOPIC: JEM 2.1: Joomla 3.4 support

JEM 2.1: Joomla 3.4 support 4 years 5 months ago #17391

  • Hoffi
  • Hoffi's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 2279
  • Karma: 52
  • Thank you received: 449
Hello everybody,

as you may know Joomla 3.4 has been released. Unfortunately there is a little bug in JEM 2.1.2 installer script which aborts installation, update or uninstallation on a Joomla 3.4 site. This problem will be fixed in JEM 2.1.3 (which I think could be released in around one week).

If you already have JEM 2.1.2 installed and then update Joomla to 3.4 JEM will simply continue to work.
Pessimists are optimists with experience!
The following user(s) said Thank You: jojo12
The topic has been locked.

JEM 2.1: Joomla 3.4 support 4 years 5 months ago #17415

  • znort
  • znort's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 42
  • Karma: 1
  • Thank you received: 16
It seems there is another bug with joomla 3.4:
in the event submission form the chooservenue returns the 500 error page .......
(only in frontend)
The following user(s) said Thank You: Hoffi
The topic has been locked.

JEM 2.1: Joomla 3.4 support 4 years 5 months ago #17416

thx for noting znort.

can confirm that the issue is there also with JEM3.
Also the language string JSelect is missing from the language front file.

hmm, some investigating to be done.
(won't respond to PM)
==================================================================
running: JEM 3.x (custom version) + Joomla 3.9.1.0 + PHP 5.x
Locally: PHP 7.3.5 + Joomla 4.0.0-alpha10 + pre-alpha JEM4.x (custom)
The topic has been locked.

JEM 2.1: Joomla 3.4 support 4 years 5 months ago #17417

alright, found the problem...

the thing here is that the modal fields of the back are loaded and basicly that's correct.

The event-form in the front is having a addfieldpath but for some kind of reason the fields in the backend are getting priority. With 3.3.x the fields in the front were having priority.

what can be done is to remove the addfieldpath but think it's better to rename the fields to venue_front/contact_front and edit the event.xml

//
maybe it has to with the JFormWrapperHelper but it can also be related to other changes.
(won't respond to PM)
==================================================================
running: JEM 3.x (custom version) + Joomla 3.9.1.0 + PHP 5.x
Locally: PHP 7.3.5 + Joomla 4.0.0-alpha10 + pre-alpha JEM4.x (custom)
Last edit: by Bluefox.
The topic has been locked.

JEM 2.1: Joomla 3.4 support 4 years 5 months ago #17422

  • Hoffi
  • Hoffi's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 2279
  • Karma: 52
  • Thank you received: 449
Thanks for reporting this znort.

That means there will be no new release until this is fixed. :(
Before I hadn't understood the details I can't say when...
Pessimists are optimists with experience!
The topic has been locked.

JEM 2.1: Joomla 3.4 support 4 years 5 months ago #17425

  • jojo12
  • jojo12's Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 3074
  • Karma: 45
  • Thank you received: 322
wrote it in github:
on my site updated Joomla 3.36 to 3.4 stable with JEM 2.1.2:
I can choose in frontend any venue and any contact without any problem!
5.5.5-10.0.30-MariaDB-0+deb8u1
PHP 7.2.9 on different sites
Apache
JEM 2.3.0dev 2.0M and specials with Joomla! 3.9.3 stable on livesites
ja_simply, ja_purity_iii, multilingual DE EN IT FR
The topic has been locked.
Time to create page: 0.244 seconds

Donate

If you find JEM useful and if you use it on your site, please consider a donation to the project.

Private Messages

You are not logged in.