Welcome, Guest
Username: Password: Remember me
This is the support for EventList 1.1.x, available here in the downloads section.

For all support requests, please provide your current versions of joomla, and of the extensions.

TOPIC:

Migration from EL1.1.X to JEM1.9.5 7 years 3 months ago #11414

  • bigbabou
  • bigbabou's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 38
  • Karma: 3
  • Thank you received: 8
Hello,

nice to see that a migration from EL 1.1 will be integrate.

I have some question about the proces.
I have installed JEM 1.9.4 on a 2.5 fresh install with Jupgrade.
table have jos25_ prefix.

In the backend in "Import Section" in "eventlist import" I have the following message :

An installation of Eventlist has not been detected.

my old eventlist table (joomla 1.5) are in the same database with prefix jos_

What is exactly the process ? can you help me ?

Please Log in or Create an account to join the conversation.

Migration from EL1.1.X to JEM1.9.5 7 years 3 months ago #11416

  • diesl
  • diesl's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 882
  • Karma: 16
  • Thank you received: 69
Currently it just looks for tables with the same prefix. So if you change the EL table names to have the jos25_ prefix, it should work.
Repository: Github // Issues: Github // Languages: Transifex

Please Log in or Create an account to join the conversation.

Migration from EL1.1.X to JEM1.9.5 7 years 3 months ago #11417

  • bigbabou
  • bigbabou's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 38
  • Karma: 3
  • Thank you received: 8
Hi diesl and thanks for your reply.

it seems that renaming table with the good prefix is not enough to JEM to detect EL installation.

in the file "views/import/tmpl/default.php" of administrator component there is a check on a variable $this->eventlistVersion line 22.

it seems that this var was initialized in the the file models/import.php in the public function getEventlistVersion (line 223) which check in extension table for an eventlist configuration.

Correct me if I'm wrong but you can't have eventlist configuration in joomla 2.5 for EL ?

I try to force this var in my template and JEM detect the EL table, but at import nothing append.

thanks for your help.

Please Log in or Create an account to join the conversation.

Migration from EL1.1.X to JEM1.9.5 7 years 3 months ago #11418

  • bigbabou
  • bigbabou's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 38
  • Karma: 3
  • Thank you received: 8
I managed to import al data from EL by adding a return='1.1' in the method getEventlistVersion but it's a quite bad way. The process should take in consediration that eventlist was not installed.

More over in Joomla 1.5 the extensions table name is __components, a fallback on this name could be a solution ?

So all event and venues are imported in back office but not displayed in front. I continue to search.

Please Log in or Create an account to join the conversation.

Migration from EL1.1.X to JEM1.9.5 7 years 3 months ago #11419

  • bigbabou
  • bigbabou's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 38
  • Karma: 3
  • Thank you received: 8
It works now.

It seems that's the process of importing doesn't fill the table jos_jem_cats_event_relations with the categorie id. All row have the catid to 0.

I just have to insert the old EL data in the JEM table and it works.

I hope my contribution will help.

Please Log in or Create an account to join the conversation.

Migration from EL1.1.X to JEM1.9.5 7 years 3 months ago #11420

  • diesl
  • diesl's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 882
  • Karma: 16
  • Thank you received: 69

it seems that renaming table with the good prefix is not enough to JEM to detect EL installation.

Thanks for your answers. You are right, there is another check. I did not think of it yesterday, I think it was just too late ;)

The check is existing, because there might be different EL versions that have to be handled differently.

Correct me if I'm wrong but you can't have eventlist configuration in joomla 2.5 for EL ?

It is possible, if you were using EL version 1.02. Furthermore I had the idea that after an upgrade process from an old Joomla version to a newer one, the old tables still can exist with the same prefix.

More over in Joomla 1.5 the extensions table name is __components, a fallback on this name could be a solution ?

Well, maybe this has to be adjusted some more. It is not yet heavily tested and we are happy about every feedback :)

Maybe it is a good idea to let people specify a custom prefix.

It seems that's the process of importing doesn't fill the table jos_jem_cats_event_relations with the categorie id. All row have the catid to 0.

Hm, it should work. Maybe there is something broken due to some recent category changes. Will have to check this.

Once again thanks for your response!
Repository: Github // Issues: Github // Languages: Transifex

Please Log in or Create an account to join the conversation.

Last edit: by diesl.
Time to create page: 0.437 seconds

Donate

If you find JEM useful and if you use it on your site, please consider a donation to the project.

Private Messages

You are not logged in.

Follow us......